Scripts IRC obsolètes

De Wiki IRC
Sauter à la navigation Sauter à la recherche

mIRC

Vous utilisez encore un script mIRC tel que Team'Script, BSmax'Script, Frisson'Script... ? Il est conseillé de le supprimer et de le remplacer par un script plus récent !

Connaitre sa version de script

Tapez ceci sur votre script mIRC: //echo -a $version

Un numéro de version s'affichera. Voici une liste des années de sorties :

N° de version mIRC Date de sortie Conseil Liste des défauts en 2020 Liste des avantages/qualités en 2020 Quelques exemples de script
3.x à 4.x Sorties entre 06 juillet 1996 et 17 octobre 2008 Obsolète SASL non-existant
Connexion par SSL/TLS non-existante
IRCv3 non-existant (ou minimal sur les versions 7.1 à 7.49)
Aucun retour à la ligne pour les longues lignes
15 couleurs d'écritures
...
Aucun BsMax'Script 7.2 et inférieurs.
Team'script 4.x et inférieurs.
Tglobe'Script 9.9 et inférieurs.
MimaScript (toutes les versions).
...
5.x Sorties entre 02 avril 1997 et 15 juin 2001
6.x Sorties entre 03 février 2002 et 17 octobre 2008
7.1 à 7.49 Sorties entre 30 juillet 2010 et 25 mai 2017
7.51 à 7.54 Sorties entre 17 septembre 2017 et 21 décembre 2018 Stable Instable pour les connexions SSL/TLS (ex: +6697) SASL ok
Connexion par SSL/TLS ok (mais parfois instable)
IRCv3 ok
Retour auto à la ligne pour les longues lignes
Nombreux autres avantages...
TglObeSCRIPT 10.1 et 10.2
7.55 à 7.63 Sorties entre 08 février 2019 et 17 août 2020 Stable SASL ok
Connexion par SSL/TLS ok
IRCv3 ok
Retour auto à la ligne pour les longues lignes
Compatible avec 98 couleurs d'écritures
Nombreux autres avantages...
RaTaM-ScRiPt 5.0
TglObeSCRIPT 10.3
TglObeSCRIPT 10.4

Pourquoi il ne faut pas utiliser une version obsolète ?

Il est déconseillé d'utiliser une version obsolète en 2020.

De nombreux script mIRC ont été créés entre 2000 et 2010, aujourd'hui en 2020 ils sont toujours sur la toile mais sont tous obsolètes car ils utilisent tous une version mirc inférieure à la 7.1. Il est conseillé d'utiliser une version 7.55 ou plus en 2020.

IRCv3 ajoute des fonctionnalités supplémentaires en plus de cela qui permet aux clients et aux serveurs de parler de manière plus standard et d'introduire de nouvelles fonctionnalités, telles que la saisie de notifications en tant que fonctionnalité de connexion améliorée (SASL) à titre d'exemples. Si vous n'utilisez pas les fonctionnalités IRCv3 dans votre client, vous utiliserez simplement IRC normalement.

L'IRCv3 ajoute aussi quelques nouveaux "raws" et ajoute aussi le "multi-lignes messages", par exemple sur un ancien script IRC, si vous tapez une très grande ligne qui dépasse 310 caractères (environ)l, la fin de votre message sera coupé et perdu, mais avec un nouveau script en version stable, la suite de votre message sera mis sur une nouvelle ligne automatiquement.

Aussi en 2008, les serveurs IRC et scripts n'utilisaient pas l'UTF-8 par défaut, et aujourd'hui en 2020 il faut utiliser obligatoirement l'UTF-8, car sans cela, il y aurait de nombreux problèmes d'affichages de caractères accentués qui vont se transformer en petits carrés...

Sur les versions obsolètes, l'option SSL/TLS n'existe pas, même chose pour une version 7.4x que j'ai testé il y a 2 ou 3 ans qui ne fonctionnait pas sur Windows 10 (option grisée) mais fonctionnait bien sur Windows 7.


Vous l'avez compris, fuyez les versions obsolètes de mIRC !